Revma US infrastructure incident | 13th of March 2026

Incident Report for RCS Cloud

Resolved

The issue is now resolved.
Posted Mar 13, 2026 - 08:27 UTC

Investigating

We are currently facing issues on the side of the infrastructure provider, in the US.
This affects the Playlist and Relay Stations usability of all regions.

We are investigating/troubleshooting since the time of the incident. Issues started affecting our service at approximately 07:30 am | UTC.
Posted Mar 13, 2026 - 08:15 UTC
This incident affected: Revma.